Introduction

Saturnin 0.30
Copyright © Décembre 2004. Runik
email : Runik
home page : Saturnin

- Visual C++ 7.10 pour le codage
- L’assembleur pour certaines instructions.
- L’OpenGL pour l'affichage vidéo.
- Lex/Flex pour le désassemblage des fichiers Saturn.
- La couche Aspi pour la lecture des cds

Ce qu'il peut faire actuellement :

- Mode Saturn : certains jeux sont jouables, d'autres montrent des choses, et certains font planter l'ému.
- Mode ST-V : même chose qu'au dessus.
- Possibilité de charger un fichier binaire (démos, etc...).
- Possibilité dechoisir la langue depuis un fichier str (qui est un fichier texte).
- Possibilité de débuggage de la Saturn (sh2, memoire, etc ... c'est utile pour les développeurs)

Ce qu'il ne sait pas faire :

Lancer un jeu directement depuis un ISO, le café, jouer aux flechettes, etc ... (Je vous laisse découvrir l'énorme potentiel de Saturnin en terme de non faisabilité :P)

Son état de maturité :

SH2 maitre : 100%
SH2 esclave: 100%
Communication maître/esclave : 50%
SMPC : 80%
Son : 20%
VDP1 : 85%
VDP2 : 70%
SCU : 80%
DSP : 0%
CD : 65%
DMA : 95%
Interruptions : 100%

Il y a 2 versions de Saturnin :
- Saturnin SDE.exe : c'est la version sans le debugger, elle est plus rapide mais parfois moins compatible.
- Saturnin.exe : c'est la version avec le debugger, elle est moins rapide mais permet de modifier l'état de l'émulateur.

J'ajouterai plusieurs choses:
- Saturnin est lent : quasiment rien n'est optimisé pour l'instant. Je me focalise sur la compatibilité en premier lieu.
- Il n'y a pas de son : j'ai travaillé dessus, mais pas suffisamment pour avoir quelque chose d'écoutable.
- Le debugger génère de gros fichiers de log.
- Certains jeux saturn (comme GT24) peuvent entrainer un bloquage du cdrom (nécessitant un redémarrage), vous êtes donc prévenus ;)


Ce qu'il faut pour qu'il gambade

Tout d'abord veillez à configurer les chemins de l'application (options->chemins).
Le mode doit aussi être sélectionné (options->mode).

Les commandes sont : (Emulateur => Saturn/ST-V)
- les touches directionnelles
- S => A
- D => B
- F => C ou jamma 1
- X => X ou jamma 2
- C => Y ou jamma 3
- V => Z ou jamma 4
- Entrée => Start
- F1 => test switch
- F2 => service switch
- F3 => ajouter crédit joueur 1
- F4 => start joueur 1
- F8 => accélère le chargement du bios ST-V
- F9 => recharge le cache des textures (à faire lorsque des couleurs bizarres sont à l'écran)


Attention !!!

Quelques jeux peuvent se comporter bizarrement, ils peuvent crasher l'ému, bloquer le cdrom, etc ...
Voici une petite liste de jeux entrainant des problèmes sur lesquels je suis tombé (j'ai testé plus de 450 jeux ...)

Saturn

GT 24
Hercs Adventure
Langrisser V
Lunar Silver Star Story
Noel 3
Panzer Dragoon Saga
Pulirula - Arcade Gears
Psychic Killer Taromaru
Samurai Shodown RPG
Shinobi Legions
Tactics Formula
Twinkle Star Sprites

ST-V

Dynamite Deka
Pro Mahjong Kiwame S
Sando-R
Suikoenbu
Virtua Fighter Kids

Comme je n'ai pas pu tester tous les jeux sortis sur le système, il peut y en avoir plus ...


Remerciements

Ses parrains :

- Ben-J, webmaster de Consollection, qui a créé et qui héberge le site. Il lui donne même souvent à manger.
- Fabien Autrel, développeur de Satourne, qui a soigné ses malformations et fractures, alors que beaucoup d'autres l'auraient achevé :)

Remerciements à

- TyRaNiD
- Charles MacDonald
- Stefano Thieso
- Bart Trzynadlowski pour l'utilisation de Turbo68K
- Stephane Dallongeville pour son core scsp
- Mariusz Wojcieszek et Haze de Mame
- la liste Segadev
- la liste Dynarec
- les communautés chez SegaXtreme, NGEmu et EmuFanatics
- l'équipe Tradu-France (Benjamin Siskoo & Frank Black) pour leur aide, leurs remarques et leurs conseils
- Zydio pour l'ensemble de son oeuvre ;)
- mon équipe de traducteurs
- mes béta-testeurs
- tous ceux qui supportent le projet
- et bien sûr encore Ben-J et Fabien !

Si vous voulez me contacter, utilisez l'adresse suivante:
saturnin@consollection.com

Avant de poser des questions spécifiques au fonctionnement de l'émulateur, n'oubliez pas de lire la FAQ, vos réponses y sont peut-être déjà !
Venez nous voir dans notre habitat naturel aussi (euh ... c'est le forum en fait ;) ) :
http://www.forum.consollection.com/index.php?c=2

Et n'oubliez pas le site web !
http://saturnin.consollection.com

A bientôt pour de nouvelles aventures !

Runik


Saturnin 0.30 FAQ

Q: C'est la première fois que j'utilise un émulateur, et quand j'appuie sur démarrer il m'envoie aussitôt le message "opcode inconnue" !
R: Vérifier que les bios soient bien déclarés (options->chemins)

Q: J'ai lancé XXX, mais j'ai le message "Operation of this cartridge is unavailable in this country"
R: Certains jeux (comme Funky Head Boxers, Find Love, Virtual Mahjong, etc...) nécessitent de configurer la machine à 1 joueur.
Pour ce faire, suivre la procédure suivante :
- Appuyer sur F2 pour passer le message
- Appuyer sur F1 pour arriver au menu de test
- Dans le menu F1 sert à valider et F2 à se diriger
- Sélectionner "System assignments"
- Changer "2P" par "1P"
- Sortir 2 fois des menus, et le jeu se lancera

Q: J'ai des choses bizarres à l'écran / il manque des portions de texte / les couleurs semblent incorrectes
R: Il est possible que certaines textures du cache soient corrompues, elles peuvent être rechargées en appuyant sur F9

Q: J'ai appuyé sur F9, mais il y a toujours des problèmes à l'écran
R: Essayer de désactiver différentes options VDP1 et VDP2 du débugger

Q: C'est toujours la foire aux slips à l'écran !!!
R: Pas de chance mon gaillard, attend une nouvelle version ;)

Q: Au secours ! J'ai lancé YYY, mais start ne démarre pas le jeu !
R: Ce problème est connu, et malheureusement il n'y a aucun moyen de le contourner pour l'instant ...

Q: J'ai une bande noire sur la partie droite de l'écran ... qui a mangé l'affichage ?
R: Pour pallier à ce problè¥, dans le debugger aller sur debug->VDP2 et cocher "forcer les plans"

Q: Saturnin tourne très lentement sur mon PC, alors que j'ai un Amintel XI à 30 Ghz, une Zorglub 74800 et 48 Go de mémoire !
R: Quasiment rien n'est optimisé pour l'instant, je me focalise dans un premier temps sur la compatibilité.

Q: Pourquoi je n'entend rien ? J'ai pourtant nettoyé mes oreilles ce matin !
R: Il n'y a pas de son dans Saturnin pour l'instant.

Q: Pourquoi il y a de gros fichiers qui sont créés par Saturnin ? J'ai quasiment plus de place pour mettre mes images de ... euh ... pingouins !
R: Ce sont des fichiers de log générés par le débµgger. Ils sont écrasés à chaque nouvelle session et peuvent être effacés sans problème.